Mamo - Payments Page Incident – Incident details

Payments Page Incident

Resolved
Partial outage
Started 28 days agoLasted 15 minutes

Affected

Payment Links

Partial outage from 2:15 AM to 2:30 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    Seems like there's an issue with our Payment links, if you're unable to open a payment link, please reach out.